Exception raised on the designer

Oystein Bjorke 6 years ago 0
This discussion was imported from CodePlex

Gimly wrote at 2013-12-05 10:58:

I don't know if it's an issue on my machine or something that came with the latest version of Oxyplot on Nuget, but something is crashing the designer as soon as I add a Plot to the XAML.

I get the following exception:
Could not load file or assembly 'System.Core, Version=, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes' or one of its dependencies. 
The system cannot find the file specified.
Any clue where that could be coming from?

objo wrote at 2013-12-06 18:25:

I tried to use the latest WPF Nuget package with VS 2013 and did not see any exceptions. What version are you using, and do you have the latest updates?

VadimCh wrote at 2013-12-07 03:02:

I have the same problem. All updates installed. I am using 2013.2.136.1 version.
When I am not using Nuget and connect source project directly - disigner worked.
Blend for Visual Studio 2013 crashing in any case.

Gimly wrote at 2013-12-09 08:27:

I'm using the latest version of OxyPlot and VS 2012 Update 4.

It's actually kind of strange, because it was working OK, and I started a new project, got OxyPlot from NuGet and in that new project I got the exception for the first time.

Then, I opened another project which and it crashed with the same exception, even though I hadn't updated the library. I tried updating, but no luck yet. It's not a big issue for me as it just crashes the designer, but I'd like to know where it's coming from.

VadimCh wrote at 2013-12-09 13:10:

Afte updates vs 2013 installation with install "silverlight sdk" all working good.
About vs 2012. Repair installation. It helped me.

Gimly wrote at 2013-12-10 14:52:

Just a quick update, I did a repair like VadimCh suggested and it indeed fixed the issue.

A bit weird, maybe an update for VS screwed something up. Anyway, I don't have the exception anymore.


badbadboy wrote at 2014-03-05 14:04:

I can confirm that for VS2013 installing Silverlight SDK fixed the issue (as VadimCh kindly pointed out).
I had VS2013 update 1, but that was not enough.